Windows10インストールと、アプリ動作確認

前に、Windows 10 Enterprise Technical PreviewをVMware Playerにインストールしたことはあったけど、今度は7/29正式版のWindows10をメインPCにインストールしてみた。
まだインストールトラブルもちらほら聞く中、自作ソフトの動作確認をしなければならないので人柱覚悟でインストール。
 

Windows10
 

と言っても、環境ぶっ壊れるといろいろ面倒なことになるので、手動で可能な限りファイルバックアップ。
に加え、以下のサイトを参考に、PCを丸ごとバックアップ。
Windows 10を入れる直前の状態で復元できるイメージバックアップのつくりかた
USBメモリに「回復ドライブ」を作成し、
外付けHDDに「システム イメージ」をごっそりバックアップ。

やらなくてもいいけど、念のため。。

 

そしてWindows10のインストール作業へ。

Windows10への無償アップグレードの予約をし、タスクトレイにWindowsアイコンが表示されている状態。
Windows10への無償アップグレードの予約

 

そろそろWin10インストールしてみようと、「Windows10を入手する」メニューを実行。
Windows10を入手する

 

あれ、入手できず「準備ができたら通知する」ボタンだけ押せる状態。
このボタンを押しても変化なし。
そのうち通知が来ると思うけど。
準備ができたら通知する

 

なにで、自分でダウンロードしてインストールしてみることに。
以下のMicrosoftのサイトからツールをダウンロード。
http://www.microsoft.com/ja-jp/software-download/windows10
MicrosoftのサイトからWindows10ダウンロードツールを入手

 

Windows10セットアップ開始。
Windows10セットアップ開始

 

Windowsをアップグレードしています
Windowsをアップグレード

 

そして、意外とすんなりWindows10化に成功。
なんか拍子抜けするぐらい簡単だった。
Windows10化

 

で、今度は自作ソフトの疎通動作確認。
ほぼそのまま動作。
自作ソフトの疎通動作確認

 

と、思ったら、、、
画像位置情報取得ツールがまともに動かない。
起動してすぐコケてしまう。
画像位置情報取得ツール

 

例外を調べてみる。
例外調査

 

落ちている所は自分の作ったソースではない所。
使い方がマズいようだが、何が原因で、呼び出し元のどこで落ちているのかわからない。

Visual Studioからデバッグ

 
Visual Studioからデバッグしてみると、Debugモードだと動作する。
そしてReleaseモードに切り替え実行すると、例外箇所で止まらず勝手にアプリが終わってしまう。
ヤバい。原因が分からない。
 

理由はまだ分かっていないけど、「管理者モード」で実行することにより回避できるっぽい。
管理者モード
GetGpsInfo.exeを右クリックして「管理者として実行」ポップアップメニューで実行。

 

管理者モードならWin10でも画像位置情報取得ツールは実行できた。
画像位置情報取得ツール

 

ちゃんとした原因調査&修正版は、しばらく先になりそう。
後日あらためてということでm(_ _)m。

 
 

それと、気になるのが、Windows10のWebブラウザ「Microsoft Edge」。
W3C標準に準拠するよう意識して作られているという事で、IE11と大分動きが違うらしい。

ということで自分が作ったWebサイトも疎通確認。
OsadaSoft
最安王
全力通販
ここら辺は、ほぼ問題ないと思う。

 

けど、
スポメカ
は、ちょっとマズイ。
まぁ、IE以外のGoogle ChromeとかFFとかでもマズかったけど。

今は、いろいろなことに手を出していて、ここまで修正する余力は無くカオスなサイトになってしまっているけど、いつかは直したい。
 
 

Windows10の話に戻すと、自作系はちょっと修正しなければならないところはあったけど、それ以外は良くも悪くもWin8.1とほぼ変わらないような感じ。
スタートメニューも、Windows7の方が良かったなぁ。アクセサリがどこ行っちゃったんだろう。
Win8系よりは良いけど。


1 comment

  1. 匿名 8月 3, 2015 2:05 am  返信

    初めまして。私のPC環境でソフト動作検証した結果を
    報告いたします。何かの参考になればと思いコメント書きます。
    PCケース:BitFenix Ronin
    マザーボード:ASUS Z97-PRO
    CPU:intel Core i7-4790K
    CPUクーラー:Scythe阿修羅
    メモリ:Corsair CMZ8GX3M2A1600C9B×2 合計16GB
    グラフィックスボード:NVIDIA GTX750Ti
    システム用SSD:Crucial CT512MX100SSD1
    ビデオ編集用SSD:intel SSDSA2MH080G2C1
    データ用HDD:WesternDigital WD30EZRX
    バックアップ用HDD:WesternDigital WD20EARS
    バックアップ用HDD:HITACHI Deakstar 0S03357
    光学ドライブ:PIONEER BDR-206BK

    ブラウザIE11最新版 問題なく起動

    グーグルクローム最新版 問題なく起動

    OPERA最新版 問題なく起動

    動画再生ソフト
    Light Alloy 問題なく起動
    (音声はwasapiレンダラー使えます)

    音楽再生ソフト
    AIMP最新版 問題なく起動
    (wasapi排他モード 48000k 24bitにて使用中)

    DAW
    studio one2 producer 2.6.2問題なく起動
    studio one3 prime問題なく起動

    セキュリティソフト
    AVAST2015問題なく起動

    オーディオドライバー
    Realtek HD最新版問題なく起動
    NVIDIA HDA最新版問題なく起動

    ディスプレイドライバー
    NVIDIA GTX750Ti 問題なく起動

    とりあえずザっとこんな感じであります。

Leave a comment

メールアドレスが公開されることはありません。

CAPTCHA


*